Как пользоваться функцией если в excel примеры

Как пользоваться функцией если в excel примеры


Примеры использования функции проверки условия (ЕСЛИ) в Excel

Функция ЕСЛИ относится к логическим функциям Microsoft Excel и является одной из наиболее часто используемых в работе. С помощью этого оператора можно выполнять различные задачи, когда необходимо сравнить какие-то данные и выдать результат. Функция ЕСЛИ в Excel дает возможность использовать в работе ветвящиеся алгоритмы, строить дерево решений и т.д.

Видео по использованию функции ЕСЛИ в Excel

Примеры использования оператора ЕСЛИ

Функция ЕСЛИ выглядит следующим образом:

=ЕСЛИ (выражение; истина; ложь).

А теперь немного подробнее:

  1. Выражение — это логическое выражение, которое может быть числом или фразой. Например «10» — это логическое выражение, «без НДС» — тоже логическое выражение. Это единственный параметр, который заполняется в обязательном порядке.
  2. Истина — значение, которое будет выдано в качестве результата, если выражение окажется истинным.
  3. Ложь — значение, которое будет выдано, если выражение будет ложным.

Простейший пример реализации функции ЕСЛИ в Excel — проверяем равенство значений двух ячеек

К примеру, можно ввести в поле C1 цифру 8, а в поле D1 написать так: =ЕСЛИ(C1<10; 1; 2). То есть программа будет сравнивать значение в поле C1 с цифрой 10, и когда оно окажется меньше 10 (C1<10), то в поле D1 будет написана единица. В противном случае программа выдаст число 2.

Следующий пример: есть список студентов, а также их оценки, которые они получили по экзамену: 5, 4, 3 и 2. Условие задачи заключается в том, что нужно для каждого студента прописать текстовый комментарий «сдал» или «не сдал». То есть если студент получил оценку 3 и выше, то он сдал экзамен, в противном случае — не сдал. Для решения этой задачи можно написать так: =ЕСЛИ(C1<3; «не сдал»; «сдал»). Excel будет сравнивать оценку каждого студента, и когда она будет меньше 3 (т.е.

двойка), то в соответствующем поле будет написан комментарий «не сдал». Если же оценка будет 3 или выше, то в ячейке будет отмечено, что этот студент сдал экзамен. По такому несложному принципу работает логическая функция ЕСЛИ в Экселе. Стоит отметить, что текстовые комментарии обязательно нужно брать в кавычки.

При использовании функции ЕСЛИ в Excel можно применять следующие операторы сравнения:

Примеры функций И, ИЛИ

Также при использовании в Экселе функции ЕСЛИ есть возможность соединить ее с простыми операторами сравнения (вроде И, ИЛИ). Например, можно написать такое условие: =ЕСЛИ(И(A1<=5; A1>3); «проходит», «не проходит»). Получается следующее условие: если оценка студента меньше или равна 5 и больше 3, то будет показан комментарий «проходит», в противном случае — «не проходит» (проходят только те студенты, у которых в оценках стоят четверки и пятерки).

Более сложный пример использования функции ЕСЛИ — с использованием условий И либо ИЛИ

Следующее условие с примером оператора ИЛИ: =ЕСЛИ(ИЛИ(A1=5; A1=10); 100; 0). Получается, что если число в ячейке А1 равняется 5 или 10, то программа выдаст 100, в противном случае — 0.

Кроме того, можно применять эти простые операторы и для решения более сложных задач. Например, в базе данных необходимо отобрать должников, которые должны более 10 тысяч рублей и уже не платили более 6 месяцев. Если программа найдет такого человека, то пусть выдаст критерий «проблемный заемщик».

Допустим, в ячейке A1 находится информация о сроке задолженности (в месяцах), а в поле B1 — сумма задолженности. Тогда формула будет выглядеть следующим образом: =ЕСЛИ(И(A1>=6; B1>10000); «проблемный заемщик»; «»). Если будет найден человек, который подходит под указанное условие, то программа напишет напротив его фамилии комментарий «проблемный заемщик», в противном случае ячейка останется пустой.

Если один из параметров считается критическим, тогда можно составить формулу так: =ЕСЛИ(ИЛИ(A1>=6; B1>10000); «критическая ситуация»; «»).

Если программа найдет совпадения хотя бы по одному параметру (либо срок, либо сумма задолженности), то пользователь увидит сообщение о том, что ситуация критическая. Разница с предыдущей формулой в том, что в первом случае сообщение «проблемный заемщик» выдавалось только тогда, когда выполнялись оба условия.

Другие примеры использования оператора ЕСЛИ

Функцию ЕСЛИ можно использовать для обхода встроенных ошибок деления на ноль, и еще в ряде случаев

Очень часто в Экселе возникает такая ошибка, как «ДЕЛ/0», т.е. деление на 0. Как правило, она появляется в техслучаях, когда копируется формула «A/B», а число B в некоторых ячейках равняется нулю. Этого можно избежать, если использовать оператор ЕСЛИ. Для этого необходимо написать так: =ЕСЛИ(B1=0; 0; A1/B1). Получается, что если в ячейке B1 будет ноль, то Excel сразу же выдаст ноль, в противном случае программа поделит A1 на B1 и выдаст результат.

Еще одна ситуация, которая довольно часто встречается на практике, расчет скидки в зависимости от общей суммы покупки. Для этого понадобится примерно такая матрица:

  • до 1000 — 0%;
  • от 1001 до 3000 — 3%;
  • от 3001 до 5000 — 5%;
  • свыше 5001 — 7%.

К примеру, в Excel есть условная база данных клиентов и информация о том, сколько они потратили на покупки. Задача состоит в том, чтобы рассчитать для них скидку. Для этого можно написать так: =ЕСЛИ(A1>=5001; B1*0,93; ЕСЛИ(А1>=3001; B1*0,95;..). Суть ясна: проверяется общая сумма покупок, и когда она, к примеру, больше 5001 рублей, то умножается на 93% стоимости товара (ячейка B1*0,93), когда больше 3001 рублей, то умножается на 95% стоимости товара и т.д. Такую формулу легко можно использовать и на практике: уровень объема продаж и уровень скидок устанавливается на ваше усмотрение.

Таким образом, применять функцию ЕСЛИ можно практически в любой ситуации, функциональность Microsoft Excel это позволяет. Главное — правильно составить формулу, чтобы результат не оказался ошибочным.


Отблагодари меня, поделись ссылкой с друзьями в социальных сетях:



как пользоваться функцией если в excel примеры, функция если в excel примеры использования с оператором условием и или:Функция ЕСЛИ в Excel примеры и задачи, которые можно решить с помощью логического оператора. Примеры простых операторов И, ИЛИ. Расчет скидки для покупателей с

как пользоваться функцией если в excel примеры

Как пользоваться функцией если в excel примеры 20 7 10